Jump to content

Enter my P.I.N. then disconnect


Recommended Posts

Blade and Soul disconnects me from the game immediately after I enter my P.I.N. with the error code (2000) (132,10054).  I've tried several times since yesterday when I first applied my Founder's Code.  Several of my friends who did not purchase the Founder's Pack get this exact same error code and disconnect when they attempt to log in.  I'm incredibly upset that my Founder's Code hasn't worked for some reason, and something about Blade and Soul support is bugged because I cannot submit a ticket with them.  I feel like I wasted my money and I'm incredibly frustrated right now, and I'm even angrier that no one from B&S seems to want to help.  I know that thousands of other people are having this same problem and I haven't seen a single official statement even acknowledging the problem.  Is anyone at all working on fixing this?  If I'm just going to get ripped off like this, and if this game has no support system in place, I don't think it's worth it to continue to try to play.

Link to comment
Share on other sites

And I just got reply from support....and it's really annoying...
See below:

Hello there,

We appreciate your interest to play Blade and Soul. Due to partnership with Innova to bring a Russian language version of Blade & Soul to the countries of Armenia, Azerbaijan, Belarus, Georgia, Kazakhstan, Kyrgyzstan, Moldova, Russia, Turkmenistan, Tajikistan, Ukraine, and Uzbekistan. NCSoft Blade and Soul NA and EU will not be able to provide service to the said countries.

If you purchased a Founder's Pack, please be informed that we have already refunded your purchase. If you still did not receive your refund, please file a refund request by contacting our support here: https://support.bladeandsoul.com/

For more information about the IP Block, please see this link:

I highly suggest that you play through Innova's Russia localized server to avoid having issues while trying to play in the NA/EU servers.

If you have any other questions, please let us know.


NCSOFT Support Team

Link to comment
Share on other sites

3 hours ago, SwiftSword said:

Did you apply the codes to your account through the website?

Of course.  I also have unistalled/reinstalled the game a couple of times and run every troubleshooting option I could find on the support pages.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...