Sign in to follow this  
Akio

A requirement for Blade and Soul failed to Install?

Recommended Posts

PingPong   

I just fixed this issue by uninstalling c++ 2015 then restarting the pc and loading the launcher hope it helps 

Share this post


Link to post
Share on other sites
Sign in to follow this