Zireael3

Members
  • Content count

    16
  • Joined

  • Last visited

About Zireael3

Recent Profile Visitors

501 profile views
  1. PLEASE FIX YOUR EU SERVERS

    Yeah, I have this problem since head start. Everything was perfect during CBT. After reporting this, someone recommended me WTFast and it made game playable again. Unfortunately my free trial just ended so I can't play now... gg NCsoft...
  2. PLEASE FIX YOUR EU SERVERS

    After dealing with your bots from "support" and not resolving the issue and telling me it's my fault I'm losing my patience. The delay on EU servers makes the game completely unplayable. And it's not only just me. Just look at this forum. My free trial on WTFast just ended and it was really good (ping reduced from150+ to 30). Everything was super smooth. Now I can't play this game. Waiting 2-3seconds until the game respond when I attack is so frustrating. EVERYTHING WAS OKAY DURING CBT SO WHAT HAVE YOU DONE TO DESTROY IT SO MUCH? PLEASE, IS THERE ANY MOD/GM WHO WOULD EXPLAIN THIS TO ME? Also is there any free alternative to WTFast or a way to make it work without paying? Would be thankful if anyone PM'ed me about it.
  3. Yeah, after a long talk with the bots from "support" and sending them every info possible about my PC and Internet they just said it's my Internet Service Provider fault and they can't do anything about it. Funny thing is every other game runs perfectly and only Blade and Soul is unplayeable.
  4. I have the same problem. Everything was allright when I played CBT and now I have 150+ ping. When I ping to Frankfurt I have around 30. Fix this please.
  5. NA maintenance on EU servers? @_@

    I play on Starfall Crater and I need to use WTFast to make the game playable. Interesting thing is that according to WTFast approximate server location is Austin, US so it looks like I'm connecting to US servers (and I have like 180 ping) through EU. With WTfast I have around 30-40 ping and the same when I ping to Frankfurt where the servers are supposed to be. Why it's like that? During CBT everything was great.
  6. Combat Lag/Delay

    Click custom game and configure. In game executable file find your Client.exe (D:\Program Files (x86)\NCSOFT\BnS\bin\Client.exe) thats mine. Then, click Run with Launcher and find the launcher file (C:\Program Files (x86)\NCWest\NCLauncher\NCLauncher.exe) Launcher parameters (/LauncherID:"NCWest" /CompanyID:"12" /GameID:"BnS" /LUpdateAddr:"updater.nclauncher.ncsoft.com) then click OK. In network tab choose "manualy customize network route" and then sort by ping. Chose the server with best ping and done. Servers are under maintance now so maybe thats why you can't run it.
  7. I play on Starfall Crater server. My ping to Frankfurt is around 40 but i have 160+ in game... I didn't play one week and I thought you will do something about servers but it's even worse. So I started the game and the first thing I noticed is over 1000+ people in queue which forced me to buy premium just to check if ping issues are solved but they are not. Also, are the EU servers really in Frankfurt? I'm forced to use WTFast to make the game playable and estimated server location is Austin, US. It's only me who is connecting to US through EU servers and getting bad ping and delay? Never had any problems during all CBT.
  8. Lag/lag spikes

    The same for me. Played CBT without problems and now unplayable due to ping.
  9. Help me pls

    It wants you to set up new code. Just type it and then remember it.
  10. Response Lag?

    It's the ping problem. Never had any when played CBT and now it is. I use WTFast to fix it but I can't do cross server dungeon that way. I don't know why, when I find the party and it counts to 0 nothing happens. It works without WTFast but delay makes the game unplayable for me.
  11. Crashes Caused by Razer and ASUS Services

    I'm happy to hear you are working on this. I don't have any Razer or Asus services and still experience lag/delay problems despite not having any through all CBT. Connecting through WTFast solved it for me partially, (I managed to get from 180 to 30 ping) but for some reason, Cross Server Dungeon doesn't work for me when I connect like this. I just hope everything will be resolved soon and I'll be able to experience smooth gameplay like when I was playing in Closed Beta.
  12. When I find the party I can't see the characters of other players, after that when the countdown to enter the dungeon hits 0 nothing happens. Everything was fine yesterday. I ran file check and restarted PC a few times. Edit: Okay, I found the fix. It only happens when I use WTFast which is strange because I was using it yesterday and everything worked. I can't play without WTFast because servers are overloaded and combat isn't smooth because of that. I will wait and maybe they will fix the servers.
  13. Cross server dungeon

    When I find the party I can't see the characters of other players, after that when the countdown to enter the dungeon hits 0 nothing happens. Everything was fine yesterday. I ran file check and restarted PC a few times. Edit: Okay, I found the fix. It only happens when I use WTFast which is strange because I was using it yesterday and everything worked. I can't play without WTFast because servers are overloaded and combat isn't smooth because of that. I will wait and maybe they will fix the servers.
  14. Combat Lag/Delay

    I had the same problem. Running the game with WTFast solved it completely.
  15. Delay in combat, ping problem?

    I don't know why it should be desktop problem but I play on Samsung LED 22. Also, I found the fix. I installed WTFast and everything runs perfectly. It shows 80-120 ping without it and 30-50 with WTFast. Everything is super smooth now like when I played in CBT so I think their serveres are just overloaded.