Jump to content
Forums

Falanyr

Members
  • Content Count

    22
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Thanks for the tips! I managed to clear him yesterday evening, thanks to this advice (and not getting dropped out of combat while I'm parrying his attacks...) - Much appreciated! It usually works after he uses his counter, assuming you can't grab/cancel that defense anyway, if that helps! He seems to resist it all for the most part before that, though :(
  2. @Cheung That almost sounds like he's triggering because you have too much DPS, but...In my case I'm barely scraping at 500AP here, so I don't think that's what could be happening on my part :( He seems like a very fickle boss! I very rarely get chance to DPS between cycles, most of the time he'll drop icicles, do that four-part combo (the one where he kicks you into the air if successful) and jump back into the middle to drop more icicles again. It's like...One in three tries I'll actually get chance to DPS him between icicle drops. Outside of the small window where he's casting the ic
  3. I've recently started attempting to beat Naksun on 15f of Mushin's tower. After much frustration I've reached the icicle phase and I'm slowly learning the timing on how to iframe those awful attacks, however...On very few attempts has he actually bothered to follow up with his combos between icicle drops. Usually I can parry said combos and phantom grip his counter to buy my iframes a little more time to cool down...But most of the time he'll just drop icicles on me. If he doesn't oneshot me, he'll just jump back to the middle and do it again. And again...And again. Naturally my iframes aren't
  4. Ah, I had the impression that collecting this 'Blazing Energy' was supposed to make you immune to that shield thing he traps you in. My friend had issues targetting the shield as the boss was still attacking me, and of course I can't dodge anything while I'm stuck so I don't last very long in that situation... Still, that sounds simple enough! The blazing energy callouts in the chat just made it sound more complex than it actually was, I think. Thanks for the advice!
  5. I realise this is probably more than a little behind the times, what with Ebondrake Citadel coming up tomorrow... Ebon Deva Gwihan, what do? Any advice? Something about blazing energy? A friend and myself have attempted it a few times but we're at a loss, so I figured it couldn't hurt to ask here. Searching seems to come up with nothing outside of the story mode version and the few videos there are don't really explain anything. Thanks in advance for any helpful replies!
  6. @Kylen Yep, I'm using a GTX 760M. Can run pretty much every other game just fine, but this one...It's just not having it, no matter what I try. I think I mentioned in an earlier post but just for reference, I can run this game on an older PC with an older GPU (Nvidia again) and while the framerates are bad, as I'd expect with the card I'm using, they're stable and I don't freeze no matter how many players are on-screen. It's really hard to pinpoint the issue and find a solution to it outside of waiting for that one optimisation patch that actually works, or something. :c
  7. I am, yes, however my sister is using an SSD and has the same problem. On the other hand, I have a friend who also plays the game using an HDD and she has no issues whatsoever, so I'm not entirely sure that's the problem either.
  8. I'm going to subtly bump this thread back up because it's still an issue and I'm not the only one dealing with it. Got excited because people were actually doing Zaiwei Ruins this morning. Hid player characters, checked optimise for combat for good measure...60FPS before the fight (even with other players showing, just to test that), hit the boss a few times, FPS plummeted to 7 before freezing for the rest of the fight. It only started responding again after the boss was dead. I'd understand it if I were constantly running at a low framerate but I'm not, so I'll just ke
  9. It certainly feels like that, I've had a stable latency for most of the week after posting this but occasionally it'll shoot up 100-150ms...Not much fun when you're trying to play KFM. :c Well...At least now I know I won't be hassling my ISP for answers. And it's probably best that I don't get my hopes up for a fix on NCSoft's end, either. Thanks for the responses though!
  10. Have you tried using the escape command on the system menu? I fell through the floor in E. Fleet as well, just used that to pop back out again and carry on.
  11. Just over the last few days my latency has increased from 60-100ms to 150-200 followed by random disconnects mid-dungeon. I assumed it was down to people in the household downloading/streaming other things, etc etc - But the issue persists even after they're done, and I'm the only one left using the internet. Makes playing most of my classes near-impossible :( So I figured I'd ask here first to find out whether it's possibly just a hiccup on the game's end or if anyone has any advice as to how I can figure out what's causing it on my end? I'm playing on Ebon Hold, if th
  12. It's probably just likely that you're unlucky with your trove options :( I've had a mixture of both crimson/cerulean insignias in troves on my characters, all of which are Cerulean order members. Don't think it's a bug though! Even if you're Cerulean you can still switch to Crimson so I guess it's still just RNG working (unfortunately) as intended.
  13. It'd be nice to get some clarification on this, I didn't see it in the patch notes either. Refiners are also no longer listed as being used with Earthseers, but bowls are instead so maybe it was intentional and just hasn't been mentioned specifically?
  14. It's not a "special program", I'm just suggesting that you check the control panel for your graphics card? For telling your laptop to run the game using your high-powered GPU instead of defaulting to integrated graphics. Otherwise you end up with low FPS and an unplayable game, like you described. What graphics card are you using?
  15. Sadly not, I've had the issue since launch as well and the game actually runs more consistently on my PC...That could barely even run WoW, just for comparison. Doesn't seem like it's been dealt with though. I heard the problem went away when they removed gameguard at some point(?) but I'd given up playing by then...And unfortunately returned shortly after it was reintroduced so I don't know if it made any difference. Doesn't seem like they plan on fixing it, either. I haven't seen any solution that actually works and it just got worse (in my case) with the most recent p
×
×
  • Create New...